Autor Thema: Im Systemlog bestimmte Meldungen ausblenden  (Gelesen 795 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Motu

  • Beiträge: 318
  • PCLOS Forum!!
Im Systemlog bestimmte Meldungen ausblenden
« am: 17.Januar.2017, 10:05:37 »
Hat vielleicht jemand von euch eine Idee, wie ich bestimmte Systemmeldungen in der /var/log/messages ausblenden bzw. unterbinden kann?
Ich bekomme ständig vom smbd die Meldung: snmpd[5022]: Wrong netlink message type 3

Ich weiss warum die Meldung kommt - aber ich möchte damit nicht die "messages" zugemüllt haben. Im Internet habe ich leider nichts gefunden. Die einzige Option, die mir unter die Finger kam, war in der /etc/init.d/snmpd das Logging auf NMPDOPTS='-LS 0-4 d -Lf /dev/null -p /var/run/snmpd.pid' zu setzen. Was leider nichts gebracht hat... Genau betrachtet kann ich da eingeben, was ich will. Die Nachricht erscheint immer wieder...  :-\

Der Vollständigkeit halber: Ich habe auch in /etc/sysconfig/snmpd die Loggingparameter geändert...
« Letzte Änderung: 17.Januar.2017, 10:54:35 von Motu »

Offline Leiche

  • Global Moderator
  • *
  • Beiträge: 608
  • Gott weiß, ich bin kein Engel
    • Tipps und Tricks
Re: Im Systemlog bestimmte Meldungen ausblenden
« Antwort #1 am: 17.Januar.2017, 18:16:38 »
Wie oft wird denn die Fehlermeldung ausgegeben?

Offline Motu

  • Beiträge: 318
  • PCLOS Forum!!
Re: Im Systemlog bestimmte Meldungen ausblenden
« Antwort #2 am: 17.Januar.2017, 21:05:45 »
Alle zwei Minuten. Auf die Sekunde genau :)

Offline planlos

  • Beiträge: 495
    • the best linux for ever
Re: Im Systemlog bestimmte Meldungen ausblenden
« Antwort #3 am: 18.Januar.2017, 12:35:32 »
Ich weiss warum die Meldung kommt
Wäre es nicht sinnvoller, den Fehler zu beheben?


Kernel 4.8.4-pclos1 - KDE: 4.14.18 - Intel(R) Pentium(R) CPU G3220 @ 3.00GHz - RAM: 8 GB - Xeon E3-1200 v4th Gen Core Processor Integrated Graphics Controller

Offline Motu

  • Beiträge: 318
  • PCLOS Forum!!
Re: Im Systemlog bestimmte Meldungen ausblenden
« Antwort #4 am: 18.Januar.2017, 14:38:47 »
Das war kein Fehler in dem Sinne. Ich hatte IPv6 abgeschaltet. Das wollte ich eigentlich auch so. Aber das gefällt snmpd wohl nicht. Doesn´t matter.
Ich habe gelesen, dass man die Protokollierung filtern kann. Allerdings funktioniert das eben nicht.

Ich dachte es gibt vielleicht eine zentrale Möglichkeit ständig wiederkehrende Meldungen ausfiltern zu können. Ich bekomme z.B. - wenn ich über VPN-Tunnel gehe - ständig diesen "IPv4: martian source"-Hinweis. Nichts Schlimmes - aber es müllt mir die Messages zu...

Offline planlos

  • Beiträge: 495
    • the best linux for ever
Re: Im Systemlog bestimmte Meldungen ausblenden
« Antwort #5 am: 18.Januar.2017, 21:14:48 »
sowas hatte ich auch mal
irgendwie habe ich es dann damals hinbekommen und die Meldung verschwand
gib uns doch einmal die komplette Fehlermeldung, vielleicht finden wir den Fehler

sicher das es an IPv6 liegt?
Zitat
"IPv4: martian source"-Hinweis
« Letzte Änderung: 18.Januar.2017, 21:17:23 von planlos »


Kernel 4.8.4-pclos1 - KDE: 4.14.18 - Intel(R) Pentium(R) CPU G3220 @ 3.00GHz - RAM: 8 GB - Xeon E3-1200 v4th Gen Core Processor Integrated Graphics Controller

Offline Motu

  • Beiträge: 318
  • PCLOS Forum!!
Re: Im Systemlog bestimmte Meldungen ausblenden
« Antwort #6 am: 18.Januar.2017, 22:29:13 »
Nein. Der "martian source"-Hinweis hat nichts mit der IPv6-Geschichte zu tun.
Es geht generell darum immer wiederkehrende Fehler (oder besser: Informationen - denn mehr ist das ja im Fall von "martian source" nicht) zu filtern bzw. zu unterbinden. Der "martian source"-Hinweis hängt unmittelbar mit VPN zusammen und ist kein Grund zur Beunruhigung. Aber gefühlte 10000 Meldungen innerhalb einer Sitzung sind dann schon nervig. Genauso war es mit der Meldung: "snmpd[5022]: Wrong netlink message type 3". Die kam auch im Abstand von exact 2 Minuten und war alleine der Abschaltung von IPv6 geschuldet.

Offline Leiche

  • Global Moderator
  • *
  • Beiträge: 608
  • Gott weiß, ich bin kein Engel
    • Tipps und Tricks
Re: Im Systemlog bestimmte Meldungen ausblenden
« Antwort #7 am: 19.Januar.2017, 06:57:16 »
Hab mich jetzt mal auch mit den Rotz beschäftigt und eventuell die Lösung ::)

Du musst eigentlich nur die folgende Datei bearbeiten:
/etc/sysconfig/snmpd
Und zwar mit folgendem Inhalt:
# (oe) added a work around for:
# http://qa.mandriva.com/show_bug.cgi?id=19388
#
# this is related to the lm_sensors mibs (#19388) "-I -lmSensors"

#OPTIONS="-Lsd -Lf /dev/null -p /var/run/snmpd -a -I -lmSensors"

OPTIONS="-LS 0-5 d -Lf /dev/null -p /var/run/snmpd -a"

Original wäre diese
# (oe) added a work around for:
# http://qa.mandriva.com/show_bug.cgi?id=19388
#
# this is related to the lm_sensors mibs (#19388) "-I -lmSensors"

OPTIONS="-Lsd -Lf /dev/null -p /var/run/snmpd -a -I -lmSensors"

Habe also nur diese Zeile eingefügt:
OPTIONS="-LS 0-5 d -Lf /dev/null -p /var/run/snmpd -a"
und die vorhandene auskommentiert mit #

Hier wurde keine weitere Zeile ausgegeben nach dem erwecken vom Bereitschaft. Eventuell habe ich aber auch den Rechner nicht lang genug in den Schlaf versetzt...

Regards
Daniel

EDIT: Okay war dann doch nicht so  ??? Fehler wird weiterhin ausgegeben...
« Letzte Änderung: 19.Januar.2017, 17:08:19 von Leiche »

Offline Motu

  • Beiträge: 318
  • PCLOS Forum!!
Re: Im Systemlog bestimmte Meldungen ausblenden
« Antwort #8 am: 19.Januar.2017, 19:19:49 »
Perfekt Daniel. Genau das ist es gewesen. Ich habe zwar hier einen Artikel darüber gefunden aber es hat nicht funktioniert.  ::) War die falsche Datei, die ich editiert habe. Jetzt klappt es!

Allerdings habe ich den Wert 0-4 verwendet. Irgendwo habe ich auch die Definition von den Zahlen gesehen (also 0 - 6). Wenn 0 - 5 eingetragen wird, kommen die Meldungen immer noch durch.

Die Martian-Meldungen habe ich auch weg bekommen. Ich habe die Firewall konfiguriert und nun kommt nichts mehr an...

Jedenfalls ziehe ich aus der Geschichte das Resumee, dass es KEINE zentrale Möglichkeit gibt, immer wiederkehrende Meldungen - von einer Stelle aus - abschalten zu können. Man muss sich quasi immer einzeln um den jeweiligen Dienst kümmern, der die Meldungsflut verursacht!? Korrigiert mich, wenn ich da falsch liege...

Jedenfalls läuft mein System im Augenblick wieder tiptop. Selbst die Systemmeldungen werden mir sauber via Postfix auf meinen MUA geschickt ;)
Somit sitze ich grinsend vor meinen Rechner und freue mich.

Danke für Eure Hilfe!

Gruß

Klaus